What’s Vulnerable › Vulnerabilities
CVE-2023-5560: WP-UserOnline < 2.88.3 - Unauthenticated Stored XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP-UserOnline WordPress plugin before 2.88.3 does not sanitise and escape the X-Forwarded-For header before outputting its content on the page, which allows unauthenticated users to perform Cross-Site Scripting attacks.
Affected products
- WP-UserOnline: before 2.88.3 — fixed in 2.88.3
How to fix
Upgrade to a fixed version: WP-UserOnline 2.88.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/55d23184-fc5a-4090-b079-142407b59b05
- https://wpscan.com/vulnerability/55d23184-fc5a-4090-b079-142407b59b05
Get alerted when CVE-2023-5560 or the next vulnerability affects your stack