What’s Vulnerable › Vulnerabilities
CVE-2023-5561: WordPress < 6.3.2 - Unauthenticated Post Author Email Disclosure
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-16 · updated 2026-06-17
Description
WordPress does not properly restrict which user fields are searchable via the REST API, allowing unauthenticated attackers to discern the email addresses of users who have published public posts on an affected website via an Oracle style attack
Affected products
- WordPress: from 4.7 before 4.7.27; from 4.8 before 4.8.23; from 4.9 before 4.9.24; from 5.0 before 5.0.20; from 5.1 before 5.1.17; from 5.2 before 5.2.19 — fixed in 4.7.27, 4.8.23, 4.9.24, 5.0.20, 5.1.17, 5.2.19
How to fix
Upgrade to a fixed version: WordPress 4.7.27, 4.8.23, 4.9.24, 5.0.20. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2023/11/msg00014.html
- https://wpscan.com/blog/email-leak-oracle-vulnerability-addressed-in-wordpress-6-3-2/
- https://wpscan.com/vulnerability/19380917-4c27-4095-abf1-eba6f913b441
- https://lists.debian.org/debian-lts-announce/2023/11/msg00014.html
- https://wpscan.com/blog/email-leak-oracle-vulnerability-addressed-in-wordpress-6-3-2/
- https://wpscan.com/vulnerability/19380917-4c27-4095-abf1-eba6f913b441
Get alerted when CVE-2023-5561 or the next vulnerability affects your stack