What’s Vulnerable › Vulnerabilities
CVE-2023-5562: Unsafe default allows for cross-site scripting attacks in KNIME Server and KNIME Business Hub
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-12 · updated 2026-06-17
- Weakness: CWE-79
Description
An unsafe default configuration in KNIME Analytics Platform before 5.2.0 allows for a cross-site scripting attack. When KNIME Analytics Platform is used as an executor for either KNIME Server or KNIME Business Hub several JavaScript-based view nodes do not sanitize the data that is displayed by default. If the data to be displayed contains JavaScript this code is executed in the browser and can perform any operations that the current user is allowed to perform silently. KNIME Analytics Platform already has configuration options with which sanitization of data can be actived, see https://docs.knime.com/latest/webportal_admin_guide/index.html#html-sanitization-webportal https://docs.knime.com/latest/webportal_admin_guide/index.html#html-sanitization-webportal . However, these are off by default which allows for cross-site scripting attacks. KNIME Analytics Platform 5.2.0 will enable sanitization by default. For all previous releases we recommend users to add the corresponding settings to the executor's knime.ini.
Affected products
- KNIME Analytics Platform: before 5.2.0 — fixed in 5.2.0
How to fix
Upgrade to a fixed version: KNIME Analytics Platform 5.2.0. Check the vendor advisory for mitigations.
References
- https://www.knime.com/security/advisories#CVE-2023-5562
- https://www.knime.com/security/advisories#CVE-2023-5562
Get alerted when CVE-2023-5562 or the next vulnerability affects your stack