What’s Vulnerable › Vulnerabilities
CVE-2023-5571: Improper Input Validation in vriteio/vrite
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-13 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation in GitHub repository vriteio/vrite prior to 0.3.0.
Affected products
- vriteio/vrite: before 0.3.0 — fixed in 0.3.0
How to fix
Upgrade to a fixed version: vriteio/vrite 0.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/vriteio/vrite/commit/1877683b932bb33fb20d688e476284b70bb9fe23
- https://huntr.dev/bounties/926ca25f-dd4a-40cf-8e6b-9d7b5938e95a
- https://github.com/vriteio/vrite/commit/1877683b932bb33fb20d688e476284b70bb9fe23
- https://huntr.dev/bounties/926ca25f-dd4a-40cf-8e6b-9d7b5938e95a
Get alerted when CVE-2023-5571 or the next vulnerability affects your stack