What’s Vulnerable › Vulnerabilities
CVE-2023-5652: WP Hotel Booking < 2.0.8 - Unauthenticated SQLi
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 63.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-20 · updated 2026-06-17
- Weakness: CWE-89
Description
The WP Hotel Booking WordPress plugin before 2.0.8 does not have authorisation and CSRF checks, as well as does not escape user input before using it in a SQL statement of a function hooked to admin_init, allowing unauthenticated users to perform SQL injections
Affected products
- thimpress WP Hotel Booking: before 2.0.8 — fixed in 2.0.8
How to fix
Upgrade to a fixed version: thimpress WP Hotel Booking 2.0.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/8ea46b9a-5239-476b-949d-49546371eac1
- https://wpscan.com/vulnerability/8ea46b9a-5239-476b-949d-49546371eac1
Get alerted when CVE-2023-5652 or the next vulnerability affects your stack