What’s Vulnerable › Vulnerabilities
CVE-2023-5703: Gift Up Gift Cards for WordPress and WooCommerce <= 2.20.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The Gift Up Gift Cards for WordPress and WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'giftup' shortcode in all versions up to, and including, 2.20.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Gift Up! Gift Up Gift Cards for WordPress and WooCommerce: before 2.20.2 — fixed in 2.20.2
How to fix
Upgrade to a fixed version: Gift Up! Gift Up Gift Cards for WordPress and WooCommerce 2.20.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/gift-up/tags/2.20.1/view/giftup-checkout.php#L46
- https://plugins.trac.wordpress.org/browser/gift-up/tags/2.20.1/view/giftup-checkout.php#L48
- https://plugins.trac.wordpress.org/changeset/2989802/gift-up#file3
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4e498706-3dbe-4c48-9c0d-0d90677aba0d?source=cve
- https://plugins.trac.wordpress.org/browser/gift-up/tags/2.20.1/view/giftup-checkout.php#L46
- https://plugins.trac.wordpress.org/browser/gift-up/tags/2.20.1/view/giftup-checkout.php#L48
- https://plugins.trac.wordpress.org/changeset/2989802/gift-up#file3
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4e498706-3dbe-4c48-9c0d-0d90677aba0d?source=cve
Get alerted when CVE-2023-5703 or the next vulnerability affects your stack