What’s Vulnerable › Vulnerabilities
CVE-2023-5747: Command injection via wave install file
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-13 · updated 2026-06-17
- Weakness: CWE-345
Description
Bashis, a Security Researcher at IPVM has found a flaw that allows for a remote code execution during the installation of Wave on the camera device. The Wave server application in camera device was vulnerable to command injection allowing an attacker to run arbitrary code. HanwhaVision has released patched firmware for the highlighted flaw. Please refer to the hanwhavision security report for more information and solution."
Affected products
- Hanwhavision Pno-A6081R-E1T Firmware: 2.21.02
- Hanwhavision Pno-A6081R-E2T Firmware: 2.21.02
- Hanwhavision Wave Server Software: before 5.1.1.37647 — fixed in 5.1.1.37647
How to fix
Upgrade to a fixed version: Hanwhavision Wave Server Software 5.1.1.37647. Check the vendor advisory for mitigations.
References
- https://www.hanwhavision.com/wp-content/uploads/2023/11/Camera-Vulnerability-Report-CVE-2023-5747_20231113.pdf
- https://www.hanwhavision.com/wp-content/uploads/2023/11/Camera-Vulnerability-Report-CVE-2023-5747_20231113.pdf
Get alerted when CVE-2023-5747 or the next vulnerability affects your stack