What’s Vulnerable › Vulnerabilities
CVE-2023-5748
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-07 · updated 2026-06-17
- Weakness: CWE-120
Description
Buffer copy without checking size of input ('Classic Buffer Overflow') vulnerability in cgi component in Synology SSL VPN Client before 1.4.7-0687 allows local users to conduct denial-of-service attacks via unspecified vectors.
Affected products
- Synology SSL VPN Client: before 1.4.7-0687 — fixed in 1.4.7-0687
How to fix
Upgrade to a fixed version: Synology SSL VPN Client 1.4.7-0687. Check the vendor advisory for mitigations.
References
- https://www.synology.com/en-global/security/advisory/Synology_SA_23_12
- https://www.synology.com/en-global/security/advisory/Synology_SA_23_12
Get alerted when CVE-2023-5748 or the next vulnerability affects your stack