What’s Vulnerable › Vulnerabilities
CVE-2023-5750: EmbedPress < 3.9.2 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-12-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The EmbedPress WordPress plugin before 3.9.2 does not sanitise and escape a parameter before outputting it back in the page containing a specific content, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Affected products
- wpdevteam EmbedPress – PDF Embedder, Embed YouTube Videos, 3D FlipBook, Social feeds, Docs & more: before 3.9.2 — fixed in 3.9.2
How to fix
Upgrade to a fixed version: wpdevteam EmbedPress – PDF Embedder, Embed YouTube Videos, 3D FlipBook, Social feeds, Docs & more 3.9.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/cf323f72-8374-40fe-9e2e-810e46de1ec8
- https://wpscan.com/vulnerability/cf323f72-8374-40fe-9e2e-810e46de1ec8
Get alerted when CVE-2023-5750 or the next vulnerability affects your stack