What’s Vulnerable › Vulnerabilities
CVE-2023-5786: GeoServer GeoWebCache rest.html direct request
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-26 · updated 2026-06-17
- Weakness: CWE-425
Description
A vulnerability was found in GeoServer GeoWebCache up to 1.15.1. It has been declared as problematic. This vulnerability affects unknown code of the file /geoserver/gwc/rest.html. The manipulation leads to direct request. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used. The identifier of this vulnerability is VDB-243592.
Affected products
- geowebcache: before 1.15.1 — fixed in 1.15.1
How to fix
Upgrade to a fixed version: geowebcache 1.15.1. Check the vendor advisory for mitigations.
References
- https://github.com/Qxyday/GeoServe---unauthorized
- https://vuldb.com/?ctiid.243592
- https://vuldb.com/?id.243592
- https://github.com/Qxyday/GeoServe---unauthorized
- https://vuldb.com/?ctiid.243592
- https://vuldb.com/?id.243592
Get alerted when CVE-2023-5786 or the next vulnerability affects your stack