What’s Vulnerable › Vulnerabilities
CVE-2023-5800: Insufficient input validation in VAPIX API create_overlay.cgi
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-05 · updated 2026-06-17
- Weakness: CWE-35
Description
Vintage, member of the AXIS OS Bug Bounty Program, has found that the VAPIX API create_overlay.cgi did not have a sufficient input validation allowing for a possible remote code execution. This flaw can only be exploited after authenticating with an operator- or administrator-privileged service account. Axis has released patched AXIS OS versions for the highlighted flaw. Please refer to the Axis security advisory for more information and solution.
Affected products
- Axis Communications AB AXIS OS: before 11.8.61 — fixed in 11.8.61
- Axis Os 2020: before 9.80.55 — fixed in 9.80.55
- Axis Os 2022: before 10.12.220 — fixed in 10.12.220
How to fix
Upgrade to a fixed version: Axis Communications AB AXIS OS 11.8.61; Axis Os 2020 9.80.55; Axis Os 2022 10.12.220. Check the vendor advisory for mitigations.
References
- https://www.axis.com/dam/public/89/d9/99/cve-2023-5800-en-US-424339.pdf
- https://www.axis.com/dam/public/89/d9/99/cve-2023-5800-en-US-424339.pdf
Get alerted when CVE-2023-5800 or the next vulnerability affects your stack