What’s Vulnerable › Vulnerabilities
CVE-2023-5838: Insufficient Session Expiration in linkstackorg/linkstack
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-29 · updated 2026-06-17
- Weakness: CWE-613
Description
Insufficient Session Expiration in GitHub repository linkstackorg/linkstack prior to v4.2.9.
Affected products
- LinkStackOrg LinkStack: before 4.2.9 — fixed in 4.2.9
How to fix
Upgrade to a fixed version: LinkStackOrg LinkStack 4.2.9. Check the vendor advisory for mitigations.
References
- https://github.com/linkstackorg/linkstack/commit/02f620092255f07e1d0252a0190fd42ef773ba05
- https://huntr.com/bounties/8f6feca3-386d-4897-801c-39b9e3e5eb03
- https://github.com/linkstackorg/linkstack/commit/02f620092255f07e1d0252a0190fd42ef773ba05
- https://huntr.com/bounties/8f6feca3-386d-4897-801c-39b9e3e5eb03
Get alerted when CVE-2023-5838 or the next vulnerability affects your stack