What’s Vulnerable › Vulnerabilities
CVE-2023-5860: Icons Font Loader <= 1.1.2 - Authenticated (Administrator+) Arbitrary File Upload
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-02 · updated 2026-06-17
- Weakness: CWE-434
Description
The Icons Font Loader plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the upload function in all versions up to, and including, 1.1.2. This makes it possible for authenticated attackers, with administrator-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible.
Affected products
- bPlugins LLC Icons Font Loader: before 1.1.3 — fixed in 1.1.3
How to fix
Upgrade to a fixed version: bPlugins LLC Icons Font Loader 1.1.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2987296/icons-font-loader
- https://www.wordfence.com/threat-intel/vulnerabilities/id/12a9fbe8-445a-478a-b6ce-cd669ccb6a2d?source=cve
- https://plugins.trac.wordpress.org/changeset/2987296/icons-font-loader
- https://www.wordfence.com/threat-intel/vulnerabilities/id/12a9fbe8-445a-478a-b6ce-cd669ccb6a2d?source=cve
Get alerted when CVE-2023-5860 or the next vulnerability affects your stack