What’s Vulnerable › Vulnerabilities
CVE-2023-5870: Postgresql: role pg_signal_backend can signal certain superuser processes.
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-10 · updated 2026-06-17
- Weakness: CWE-400
Description
A flaw was found in PostgreSQL involving the pg_cancel_backend role that signals background workers, including the logical replication launcher, autovacuum workers, and the autovacuum launcher. Successful exploitation requires a non-core extension with a less-resilient background worker and would affect that specific background worker only. This issue may allow a remote high privileged user to launch a denial of service (DoS) attack.
Affected products
- PostgreSQL: from 11.0 before 11.22; from 12.0 before 12.17; from 13.0 before 13.13; from 14.0 before 14.10; from 15.0 before 15.5; 16.0 — fixed in 11.22, 12.17, 13.13, 14.10, 15.5
- RedHat Codeready Linux Builder Eus: 9.2
- RedHat Codeready Linux Builder Eus For Power Little Endian Eus: 9.0_ppc64le, 9.2_ppc64le
- RedHat Codeready Linux Builder For Arm64 Eus: 8.6_aarch64, 9.0_aarch64, 9.2_aarch64
- RedHat Codeready Linux Builder For Ibm Z Systems Eus: 9.0_s390x, 9.2_s390x
- RedHat Codeready Linux Builder For Power Little Endian Eus: 9.0_ppc64le, 9.2_ppc64le
- Red Hat Enterprise Linux: 8.0, 9.0
- RedHat Enterprise Linux Eus: 8.6, 8.8, 9.0, 9.2
- RedHat Enterprise Linux For Arm 64: 8.0, 8.8_aarch64
- RedHat Enterprise Linux For Ibm Z Systems: 8.0_s390x
- RedHat Enterprise Linux For Ibm Z Systems Eus: 8.6_s390x, 8.8_s390x, 9.0_s390x, 9.2_s390x
- RedHat Enterprise Linux For Power Little Endian: 8.0_ppc64le
- RedHat Enterprise Linux For Power Little Endian Eus: 8.6_ppc64le, 8.8_ppc64le, 9.0_ppc64le, 9.2_ppc64le
- RedHat Enterprise Linux Server Aus: 8.2, 8.4, 8.6, 9.2
- RedHat Enterprise Linux Server Tus: 8.2, 8.4, 8.6
- RedHat Software Collections: 1.0
How to fix
Upgrade to a fixed version: PostgreSQL 11.22, 12.17, 13.13, 14.10. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2023:7545
- https://access.redhat.com/errata/RHSA-2023:7579
- https://access.redhat.com/errata/RHSA-2023:7580
- https://access.redhat.com/errata/RHSA-2023:7581
- https://access.redhat.com/errata/RHSA-2023:7616
- https://access.redhat.com/errata/RHSA-2023:7656
- https://access.redhat.com/errata/RHSA-2023:7666
- https://access.redhat.com/errata/RHSA-2023:7667
- https://access.redhat.com/errata/RHSA-2023:7694
- https://access.redhat.com/errata/RHSA-2023:7695
- https://access.redhat.com/errata/RHSA-2023:7714
- https://access.redhat.com/errata/RHSA-2023:7770
Get alerted when CVE-2023-5870 or the next vulnerability affects your stack