What’s Vulnerable › Vulnerabilities
CVE-2023-5889: Insufficient Session Expiration in pkp/pkp-lib
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-01 · updated 2026-06-17
- Weakness: CWE-613
Description
Insufficient Session Expiration in GitHub repository pkp/pkp-lib prior to 3.3.0-16.
Affected products
- Pkp Web Application Library: before 3.3.0-16 — fixed in 3.3.0-16
How to fix
Upgrade to a fixed version: Pkp Web Application Library 3.3.0-16. Check the vendor advisory for mitigations.
References
- https://github.com/pkp/pkp-lib/commit/32d071ef2090fc336bc17d56a86d1dff90c26f0b
- https://huntr.com/bounties/fba2991a-1b8a-4c89-9689-d708526928e1
- https://github.com/pkp/pkp-lib/commit/32d071ef2090fc336bc17d56a86d1dff90c26f0b
- https://huntr.com/bounties/fba2991a-1b8a-4c89-9689-d708526928e1
Get alerted when CVE-2023-5889 or the next vulnerability affects your stack