What’s Vulnerable › Vulnerabilities
CVE-2023-5891: Cross-site Scripting (XSS) - Reflected in pkp/pkp-lib
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-01 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Reflected in GitHub repository pkp/pkp-lib prior to 3.3.0-16.
Affected products
- Sfu Pkp Web Application Library: before 3.3.0-16 — fixed in 3.3.0-16
How to fix
Upgrade to a fixed version: Sfu Pkp Web Application Library 3.3.0-16. Check the vendor advisory for mitigations.
References
- https://github.com/pkp/pkp-lib/commit/d4111c4d0eef783f1ed2e55654a5b83d9d527d97
- https://huntr.com/bounties/ce4956e4-9ef5-4e0e-bfb2-481ec5cfb0a5
- https://github.com/pkp/pkp-lib/commit/d4111c4d0eef783f1ed2e55654a5b83d9d527d97
- https://huntr.com/bounties/ce4956e4-9ef5-4e0e-bfb2-481ec5cfb0a5
Get alerted when CVE-2023-5891 or the next vulnerability affects your stack