What’s Vulnerable › Vulnerabilities
CVE-2023-5892: Cross-site Scripting (XSS) - Stored in pkp/pkp-lib
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-01 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository pkp/pkp-lib prior to 3.3.0-16.
Affected products
- Sfu Pkp Web Application Library: before 3.3.0-16 — fixed in 3.3.0-16
How to fix
Upgrade to a fixed version: Sfu Pkp Web Application Library 3.3.0-16. Check the vendor advisory for mitigations.
References
- https://github.com/pkp/pkp-lib/commit/a0485a5c7410821e0432c079ca676ee6026bffb9
- https://huntr.com/bounties/16719252-d88d-43cc-853a-24ff75a067d8
- https://github.com/pkp/pkp-lib/commit/a0485a5c7410821e0432c079ca676ee6026bffb9
- https://huntr.com/bounties/16719252-d88d-43cc-853a-24ff75a067d8
Get alerted when CVE-2023-5892 or the next vulnerability affects your stack