What’s Vulnerable › Vulnerabilities
CVE-2023-5894: Cross-site Scripting (XSS) - Stored in pkp/ojs
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-01 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository pkp/ojs prior to 3.3.0-16.
Affected products
- PKP Open Journal Systems: before 3.3.0-16 — fixed in 3.3.0-16
How to fix
Upgrade to a fixed version: PKP Open Journal Systems 3.3.0-16. Check the vendor advisory for mitigations.
References
- https://github.com/pkp/ojs/commit/66927de1a82e3a3004db9741d1505ddac0980e63
- https://huntr.com/bounties/aba3ba5b-aa6b-4076-b663-4237b4a0761d
- https://github.com/pkp/ojs/commit/66927de1a82e3a3004db9741d1505ddac0980e63
- https://huntr.com/bounties/aba3ba5b-aa6b-4076-b663-4237b4a0761d
Get alerted when CVE-2023-5894 or the next vulnerability affects your stack