What’s Vulnerable › Vulnerabilities
CVE-2023-5895: Cross-site Scripting (XSS) - DOM in pkp/pkp-lib
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-01 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - DOM in GitHub repository pkp/pkp-lib prior to 3.3.0-16.
Affected products
- Sfu Pkp Web Application Library: before 3.3.0-16 — fixed in 3.3.0-16
How to fix
Upgrade to a fixed version: Sfu Pkp Web Application Library 3.3.0-16. Check the vendor advisory for mitigations.
References
- https://github.com/pkp/pkp-lib/commit/83fa560d6fb54458b312addd23a91ee6520dbe63
- https://huntr.com/bounties/2cc80417-32b2-4024-bbcd-d95a039c11ae
- https://github.com/pkp/pkp-lib/commit/83fa560d6fb54458b312addd23a91ee6520dbe63
- https://huntr.com/bounties/2cc80417-32b2-4024-bbcd-d95a039c11ae
Get alerted when CVE-2023-5895 or the next vulnerability affects your stack