What’s Vulnerable › Vulnerabilities
CVE-2023-5896: Cross-site Scripting (XSS) - Stored in pkp/pkp-lib
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-01 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository pkp/pkp-lib prior to 3.4.0-4.
Affected products
- Sfu Pkp Web Application Library: before 3.4.0-4 — fixed in 3.4.0-4
How to fix
Upgrade to a fixed version: Sfu Pkp Web Application Library 3.4.0-4. Check the vendor advisory for mitigations.
References
- https://github.com/pkp/pkp-lib/commit/18b318f83105ffa7fa214179f8e20507b0754236
- https://huntr.com/bounties/a1f05be5-24ed-4ec5-9858-fce4233f7bb1
- https://github.com/pkp/pkp-lib/commit/18b318f83105ffa7fa214179f8e20507b0754236
- https://huntr.com/bounties/a1f05be5-24ed-4ec5-9858-fce4233f7bb1
Get alerted when CVE-2023-5896 or the next vulnerability affects your stack