What’s Vulnerable › Vulnerabilities
CVE-2023-5898: Cross-Site Request Forgery (CSRF) in pkp/pkp-lib
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-01 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) in GitHub repository pkp/pkp-lib prior to 3.3.0-16.
Affected products
- Pkp Web Application Library: before 3.3.0-16 — fixed in 3.3.0-16
How to fix
Upgrade to a fixed version: Pkp Web Application Library 3.3.0-16. Check the vendor advisory for mitigations.
References
- https://github.com/pkp/pkp-lib/commit/01feef7a9392d314bf75b97a7e099cf0a307acd9
- https://huntr.com/bounties/19801d12-b8ad-45e7-86e1-8f0230667c9e
- https://github.com/pkp/pkp-lib/commit/01feef7a9392d314bf75b97a7e099cf0a307acd9
- https://huntr.com/bounties/19801d12-b8ad-45e7-86e1-8f0230667c9e
Get alerted when CVE-2023-5898 or the next vulnerability affects your stack