What’s Vulnerable › Vulnerabilities
CVE-2023-5900: Cross-Site Request Forgery in pkp/pkp-lib
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-07 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery in GitHub repository pkp/pkp-lib prior to 3.3.0-16.
Affected products
- Sfu Pkp Web Application Library: before 3.3.0-16 — fixed in 3.3.0-16
How to fix
Upgrade to a fixed version: Sfu Pkp Web Application Library 3.3.0-16. Check the vendor advisory for mitigations.
References
- https://github.com/pkp/pkp-lib/commit/4d77a00be9050fac7eb8d2d1cbedcdaaa1a5a803
- https://huntr.com/bounties/c3f011d4-9f76-4b2b-b3d4-a5e2ecd2e354
- https://github.com/pkp/pkp-lib/commit/4d77a00be9050fac7eb8d2d1cbedcdaaa1a5a803
- https://huntr.com/bounties/c3f011d4-9f76-4b2b-b3d4-a5e2ecd2e354
Get alerted when CVE-2023-5900 or the next vulnerability affects your stack