What’s Vulnerable › Vulnerabilities
CVE-2023-5901: Cross-site Scripting in pkp/pkp-lib
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-07 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting in GitHub repository pkp/pkp-lib prior to 3.3.0-16.
Affected products
- Sfu Pkp Web Application Library: before 3.3.0-16 — fixed in 3.3.0-16
How to fix
Upgrade to a fixed version: Sfu Pkp Web Application Library 3.3.0-16. Check the vendor advisory for mitigations.
References
- https://github.com/pkp/pkp-lib/commit/44d8bde60eb2575fd4087b76540aec9b49389e23
- https://huntr.com/bounties/8fb9b06b-cadd-469e-862d-5ce026019597
- https://github.com/pkp/pkp-lib/commit/44d8bde60eb2575fd4087b76540aec9b49389e23
- https://huntr.com/bounties/8fb9b06b-cadd-469e-862d-5ce026019597
Get alerted when CVE-2023-5901 or the next vulnerability affects your stack