What’s Vulnerable › Vulnerabilities
CVE-2023-5922: Royal Elementor Addons and Templates < 1.3.81 - Unauthenticated Arbitrary Post Read
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-16 · updated 2026-06-17
Description
The Royal Elementor Addons and Templates WordPress plugin before 1.3.81 does not ensure that users accessing posts via an AJAX action (and REST endpoint, currently disabled in the plugin) have the right to do so, allowing unauthenticated users to access arbitrary draft, private and password protected posts/pages content
Affected products
- wproyal Royal Addons for Elementor – Addons and Templates Kit for Elementor: before 1.3.81 — fixed in 1.3.81
How to fix
Upgrade to a fixed version: wproyal Royal Addons for Elementor – Addons and Templates Kit for Elementor 1.3.81. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/debd8498-5770-4270-9ee1-1503e675ef34/
- https://wpscan.com/vulnerability/debd8498-5770-4270-9ee1-1503e675ef34/
Get alerted when CVE-2023-5922 or the next vulnerability affects your stack