What’s Vulnerable › Vulnerabilities
CVE-2023-5931: rtMedia for WordPress, BuddyPress and bbPress < 4.6.16 - Subscriber+ RCE
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-12-26 · updated 2026-06-17
- Weakness: CWE-434
Description
The rtMedia for WordPress, BuddyPress and bbPress WordPress plugin before 4.6.16 does not validate files to be uploaded, which could allow attackers with a low-privilege account (e.g. subscribers) to upload arbitrary files such as PHP on the server
Affected products
- rtMedia for WordPress, BuddyPress and bbPress: before 4.6.16 — fixed in 4.6.16
How to fix
Upgrade to a fixed version: rtMedia for WordPress, BuddyPress and bbPress 4.6.16. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3d6889e3-a01b-4e7f-868f-af7cc8c7531a
- https://wpscan.com/vulnerability/3d6889e3-a01b-4e7f-868f-af7cc8c7531a
Get alerted when CVE-2023-5931 or the next vulnerability affects your stack