What’s Vulnerable › Vulnerabilities
CVE-2023-5942: Medialist < 1.4.1 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The Medialist WordPress plugin before 1.4.1 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- D. Relton Medialist: before 1.4.1 — fixed in 1.4.1
How to fix
Upgrade to a fixed version: D. Relton Medialist 1.4.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/914559e1-eed5-4a69-8371-a48055835453
- https://wpscan.com/vulnerability/914559e1-eed5-4a69-8371-a48055835453
Get alerted when CVE-2023-5942 or the next vulnerability affects your stack