What’s Vulnerable › Vulnerabilities
CVE-2023-5950: Rapid7 Velociraptor Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-06 · updated 2026-06-17
- Weakness: CWE-79
Description
Rapid7 Velociraptor versions prior to 0.7.0-4 suffer from a reflected cross site scripting vulnerability. This vulnerability allows attackers to inject JS into the error path, potentially leading to unauthorized execution of scripts within a user's web browser. This vulnerability is fixed in version 0.7.0-04 and a patch is available to download. Patches are also available for version 0.6.9 (0.6.9-1).
Affected products
- Rapid7 Velociraptor: before 0.6.9-1; 0.7.0, 0.7.0-rc1, 0.7.0-3 — fixed in 0.6.9-1
How to fix
Upgrade to a fixed version: Rapid7 Velociraptor 0.6.9-1. Check the vendor advisory for mitigations.
References
- https://github.com/Velocidex/velociraptor/releases/tag/v0.7.0
- https://github.com/Velocidex/velociraptor/releases/tag/v0.7.0
Get alerted when CVE-2023-5950 or the next vulnerability affects your stack