What’s Vulnerable › Vulnerabilities
CVE-2023-5951: Welcart e-Commerce < 2.9.5 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-12-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The Welcart e-Commerce WordPress plugin before 2.9.5 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Affected products
- Welcart e-Commerce: before 2.9.5 — fixed in 2.9.5
How to fix
Upgrade to a fixed version: Welcart e-Commerce 2.9.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/81dc093a-545d-4bcd-ab85-ee9472d709e5
- https://wpscan.com/vulnerability/81dc093a-545d-4bcd-ab85-ee9472d709e5
Get alerted when CVE-2023-5951 or the next vulnerability affects your stack