What’s Vulnerable › Vulnerabilities
CVE-2023-5952: Welcart e-Commerce < 2.9.5 - Unauthenticated PHP Object Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-12-04 · updated 2026-06-17
Description
The Welcart e-Commerce WordPress plugin before 2.9.5 unserializes user input from cookies, which could allow unautehtniacted users to perform PHP Object Injection when a suitable gadget is present on the blog
Affected products
- Welcart e-Commerce: before 2.9.5 — fixed in 2.9.5
How to fix
Upgrade to a fixed version: Welcart e-Commerce 2.9.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0acd613e-dbd6-42ae-9f3d-6d6e77a4c1b7
- https://wpscan.com/vulnerability/0acd613e-dbd6-42ae-9f3d-6d6e77a4c1b7
Get alerted when CVE-2023-5952 or the next vulnerability affects your stack