What’s Vulnerable › Vulnerabilities
CVE-2023-5953: Welcart e-Commerce < 2.9.5 - Subscriber+ Arbitrary File Upload
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-12-04 · updated 2026-06-17
- Weakness: CWE-434
Description
The Welcart e-Commerce WordPress plugin before 2.9.5 does not validate files to be uploaded, as well as does not have authorisation and CSRF in an AJAX action handling such upload. As a result, any authenticated users, such as subscriber could upload arbitrary files, such as PHP on the server
Affected products
- Welcart e-Commerce: before 2.9.5 — fixed in 2.9.5
How to fix
Upgrade to a fixed version: Welcart e-Commerce 2.9.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6d29ba12-f14a-4cee-baae-a6049d83bce6
- https://wpscan.com/vulnerability/6d29ba12-f14a-4cee-baae-a6049d83bce6
Get alerted when CVE-2023-5953 or the next vulnerability affects your stack