What’s Vulnerable › Vulnerabilities
CVE-2023-5958: POST SMTP Mailer < 2.7.1 - Unauthenticated Cross-site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The POST SMTP Mailer WordPress plugin before 2.7.1 does not escape email message content before displaying it in the backend, allowing an unauthenticated attacker to perform XSS attacks against highly privileged users.
Affected products
- saadiqbal Post SMTP – Complete Email Deliverability and SMTP Solution with Email Logs, Alerts, Backup SMTP & Mobile App: before 2.7.1 — fixed in 2.7.1
How to fix
Upgrade to a fixed version: saadiqbal Post SMTP – Complete Email Deliverability and SMTP Solution with Email Logs, Alerts, Backup SMTP & Mobile App 2.7.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/22fa478d-e42e-488d-9b4b-a8720dec7cee
- https://wpscan.com/vulnerability/22fa478d-e42e-488d-9b4b-a8720dec7cee
Get alerted when CVE-2023-5958 or the next vulnerability affects your stack