What’s Vulnerable › Vulnerabilities
CVE-2023-5961: ioLogik E1200 Series: Cross-Site Request Forgery (CSRF) Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-23 · updated 2026-06-17
- Weakness: CWE-352
Description
A Cross-Site Request Forgery (CSRF) vulnerability has been identified in ioLogik E1200 Series firmware versions v3.3 and prior. An attacker can exploit this vulnerability to trick a client into making an unintentional request to the web server, which will be treated as an authentic request. This vulnerability may lead an attacker to perform operations on behalf of the victimized user.
Affected products
- Moxa Iologik E1210 Firmware: before 3.3 — fixed in 3.3
- Moxa Iologik E1211 Firmware: before 3.3 — fixed in 3.3
- Moxa Iologik E1212 Firmware: before 3.3 — fixed in 3.3
- Moxa Iologik E1213 Firmware: before 3.3 — fixed in 3.3
- Moxa Iologik E1214 Firmware: before 3.3 — fixed in 3.3
- Moxa Iologik E1240 Firmware: before 3.3 — fixed in 3.3
- Moxa Iologik E1241 Firmware: before 3.3 — fixed in 3.3
- Moxa Iologik E1242 Firmware: before 3.3 — fixed in 3.3
- Moxa Iologik E1260 Firmware: before 3.3 — fixed in 3.3
- Moxa Iologik E1262 Firmware: before 3.3 — fixed in 3.3
How to fix
Upgrade to a fixed version: Moxa Iologik E1210 Firmware 3.3; Moxa Iologik E1211 Firmware 3.3; Moxa Iologik E1212 Firmware 3.3; Moxa Iologik E1213 Firmware 3.3; Moxa Iologik E1214 Firmware 3.3; Moxa Iologik E1240 Firmware 3.3; Moxa Iologik E1241 Firmware 3.3; Moxa Iologik E1242 Firmware 3.3; Moxa Iologik E1260 Firmware 3.3; Moxa Iologik E1262 Firmware 3.3. Check the vendor advisory for mitigations.
References
- https://www.moxa.com/en/support/product-support/security-advisory/mpsa-235250-iologik-e1200-series-web-server-vulnerability
- https://www.moxa.com/en/support/product-support/security-advisory/mpsa-235250-iologik-e1200-series-web-server-vulnerability
Get alerted when CVE-2023-5961 or the next vulnerability affects your stack