What’s Vulnerable › Vulnerabilities

CVE-2023-5963: Allocation of Resources Without Limits or Throttling in GitLab

Description

An issue has been discovered in GitLab EE with Advanced Search affecting all versions from 13.9 to 16.3.6, 16.4 prior to 16.4.2 and 16.5 prior to 16.5.1 that could allow a denial of service in the Advanced Search function by chaining too many syntax operators.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.4.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-5963 or the next vulnerability affects your stack