What’s Vulnerable › Vulnerabilities
CVE-2023-6002: Log Injection
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-08 · updated 2026-06-17
- Weakness: CWE-117
Description
YugabyteDB is vulnerable to cross site scripting (XSS) via log injection. Writing invalidated user input to log files can allow an unprivileged attacker to forge log entries or inject malicious content into the logs.
Affected products
- YugabyteDB: from 2.14.0.0 before 2.14.14.0; from 2.16.0.0 before 2.16.8.0; from 2.18.0.0 before 2.18.4.0 — fixed in 2.14.14.0, 2.16.8.0, 2.18.4.0
How to fix
Upgrade to a fixed version: YugabyteDB 2.14.14.0, 2.16.8.0, 2.18.4.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-6002 or the next vulnerability affects your stack