What’s Vulnerable › Vulnerabilities
CVE-2023-6004: Libssh: proxycommand/proxyjump features allow injection of malicious code through hostname
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-03 · updated 2026-06-17
- Weakness: CWE-74
Description
A flaw was found in libssh. By utilizing the ProxyCommand or ProxyJump feature, users can exploit unchecked hostname syntax on the client. This issue may allow an attacker to inject malicious code into the command of the features mentioned through the hostname parameter.
Affected products
- Fedoraproject Fedora: 38
- libssh: from 0.8.0 before 0.9.8; from 0.10.0 before 0.10.6 — fixed in 0.10.6, 0.9.8
- Red Hat Enterprise Linux: 8.0, 9.0
How to fix
Upgrade to a fixed version: libssh 0.10.6, 0.9.8. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2024:2504
- https://access.redhat.com/errata/RHSA-2024:3233
- https://access.redhat.com/security/cve/CVE-2023-6004
- https://bugzilla.redhat.com/show_bug.cgi?id=2251110
- https://www.libssh.org/security/advisories/CVE-2023-6004.txt
- https://access.redhat.com/errata/RHSA-2024:2504
- https://access.redhat.com/errata/RHSA-2024:3233
- https://access.redhat.com/security/cve/CVE-2023-6004
- https://bugzilla.redhat.com/show_bug.cgi?id=2251110
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/LZQVUHWVWRH73YBXUQJOD6CKHDQBU3DM/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MKQRBF3DWMWPH36LBCOBUTSIZRTPEZXB/
- https://security.netapp.com/advisory/ntap-20240223-0004/
Get alerted when CVE-2023-6004 or the next vulnerability affects your stack