What’s Vulnerable › Vulnerabilities
CVE-2023-6035: EazyDocs < 2.3.4 - Subscriber + SQLi
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-12-11 · updated 2026-06-17
- Weakness: CWE-89
Description
The EazyDocs WordPress plugin before 2.3.4 does not properly sanitize and escape "data" parameter before using it in an SQL statement via an AJAX action, which could allow any authenticated users, such as subscribers, to perform SQL Injection attacks.
Affected products
- EazyDocs: before 2.3.4 — fixed in 2.3.4
How to fix
Upgrade to a fixed version: EazyDocs 2.3.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/44f5a29a-05f9-40d2-80f2-6fb2bda60d79
- https://wpscan.com/vulnerability/44f5a29a-05f9-40d2-80f2-6fb2bda60d79
Get alerted when CVE-2023-6035 or the next vulnerability affects your stack