What’s Vulnerable › Vulnerabilities
CVE-2023-6064: PayHere Payment Gateway < 2.2.12 - Unauthenticated Log Data Disclosure
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-01 · updated 2026-06-17
- Weakness: CWE-532
Description
The PayHere Payment Gateway WordPress plugin before 2.2.12 automatically creates publicly-accessible log files containing sensitive information when transactions occur.
Affected products
- PayHere Payment Gateway: before 2.2.12 — fixed in 2.2.12
How to fix
Upgrade to a fixed version: PayHere Payment Gateway 2.2.12. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/423c8881-628b-4380-9677-65b3f5165efe
- https://wpscan.com/vulnerability/423c8881-628b-4380-9677-65b3f5165efe
Get alerted when CVE-2023-6064 or the next vulnerability affects your stack