What’s Vulnerable › Vulnerabilities
CVE-2023-6119
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-16 · updated 2026-06-17
- Weakness: CWE-269
Description
An Improper Privilege Management vulnerability in Trellix GetSusp prior to version 5.0.0.27 allows a local, low privilege attacker to gain access to files that usually require a higher privilege level. This is caused by GetSusp not correctly protecting a directory that it creates during execution, allowing an attacker to take over file handles used by GetSusp. As this runs with high privileges, the attacker gains elevated permissions. The file handles are opened as read-only.
Affected products
- Trellix GetSusp: before 5.0.0.27 — fixed in 5.0.0.27
How to fix
Upgrade to a fixed version: Trellix GetSusp 5.0.0.27. Check the vendor advisory for mitigations.
References
- https://kcm.trellix.com/corporate/index?page=content&id=SB10412
- https://kcm.trellix.com/corporate/index?page=content&id=SB10412
Get alerted when CVE-2023-6119 or the next vulnerability affects your stack