What’s Vulnerable › Vulnerabilities
CVE-2023-6146: Stored XSS Vulnerability in QualysGuard VM/PC
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-08 · updated 2026-06-17
- Weakness: CWE-79
Description
A Qualys web application was found to have a stored XSS vulnerability resulting from the absence of HTML encoding in the presentation of logging information to users. This vulnerability allowed a user with login access to the application to introduce XSS payload via browser details.
Affected products
- Qualys Private Cloud Platform: before 10.24.0.0 — fixed in 10.24.0.0
How to fix
Upgrade to a fixed version: Qualys Private Cloud Platform 10.24.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-6146 or the next vulnerability affects your stack