What’s Vulnerable › Vulnerabilities
CVE-2023-6165: Restrict Usernames Emails Characters Plugin < 3.1.4 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The Restrict Usernames Emails Characters WordPress plugin before 3.1.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed
Affected products
- Restrict Usernames Emails Characters: before 3.1.4 — fixed in 3.1.4
How to fix
Upgrade to a fixed version: Restrict Usernames Emails Characters 3.1.4. Check the vendor advisory for mitigations.
References
- https://github.com/youki992/youki992.github.io/blob/master/others/apply2.md
- https://wpscan.com/vulnerability/aba62286-9a82-4d5b-9b47-1fddde5da487/
- https://github.com/youki992/youki992.github.io/blob/master/others/apply2.md
- https://wpscan.com/vulnerability/aba62286-9a82-4d5b-9b47-1fddde5da487/
Get alerted when CVE-2023-6165 or the next vulnerability affects your stack