What’s Vulnerable › Vulnerabilities
CVE-2023-6185: Improper input validation enabling arbitrary Gstreamer pipeline injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-11 · updated 2026-06-17
Description
Improper Input Validation vulnerability in GStreamer integration of The Document Foundation LibreOffice allows an attacker to execute arbitrary GStreamer plugins. In affected versions the filename of the embedded video is not sufficiently escaped when passed to GStreamer enabling an attacker to run arbitrary gstreamer plugins depending on what plugins are installed on the target system.
Affected products
- Debian Linux: 11.0, 12.0
- Fedoraproject Fedora: 38
- The Document Foundation LibreOffice: from 7.5.0 before 7.5.9; from 7.6.0 before 7.6.3 — fixed in 7.5.9, 7.6.3
How to fix
Upgrade to a fixed version: The Document Foundation LibreOffice 7.5.9, 7.6.3. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2023/12/msg00026.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/QB7UB6CTWQUDOE657OVVRSDYUY3IPBJG/
- https://www.debian.org/security/2023/dsa-5574
- https://www.libreoffice.org/about-us/security/advisories/cve-2023-6185
- https://lists.debian.org/debian-lts-announce/2023/12/msg00026.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/QB7UB6CTWQUDOE657OVVRSDYUY3IPBJG/
- https://www.debian.org/security/2023/dsa-5574
- https://www.libreoffice.org/about-us/security/advisories/cve-2023-6185
Get alerted when CVE-2023-6185 or the next vulnerability affects your stack