What’s Vulnerable › Vulnerabilities
CVE-2023-6186: Link targets allow arbitrary script execution
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-11 · updated 2026-06-17
- Weakness: CWE-281
Description
Insufficient macro permission validation of The Document Foundation LibreOffice allows an attacker to execute built-in macros without warning. In affected versions LibreOffice supports hyperlinks with macro or similar built-in command targets that can be executed when activated without warning the user.
Affected products
- Debian Linux: 11.0, 12.0
- Fedoraproject Fedora: 38
- The Document Foundation LibreOffice: from 7.5.0 before 7.5.9; from 7.6.0 before 7.6.4 — fixed in 7.5.9, 7.6.4
How to fix
Upgrade to a fixed version: The Document Foundation LibreOffice 7.5.9, 7.6.4. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2023/12/msg00026.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/QB7UB6CTWQUDOE657OVVRSDYUY3IPBJG/
- https://www.debian.org/security/2023/dsa-5574
- https://www.libreoffice.org/about-us/security/advisories/cve-2023-6186
- https://lists.debian.org/debian-lts-announce/2023/12/msg00026.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/QB7UB6CTWQUDOE657OVVRSDYUY3IPBJG/
- https://www.debian.org/security/2023/dsa-5574
- https://www.libreoffice.org/about-us/security/advisories/cve-2023-6186
Get alerted when CVE-2023-6186 or the next vulnerability affects your stack