What’s Vulnerable › Vulnerabilities
CVE-2023-6207
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-21 · updated 2026-06-17
- Weakness: CWE-416
Description
Ownership mismanagement led to a use-after-free in ReadableByteStreams This vulnerability affects Firefox < 120, Firefox ESR < 115.5.0, and Thunderbird < 115.5.
Affected products
- Debian Linux: 10.0, 11.0, 12.0
- Mozilla Firefox: before 120.0 — fixed in 120.0
- Mozilla Firefox ESR: before 115.5.0 — fixed in 115.5.0
- Mozilla Thunderbird: before 115.5 — fixed in 115.5
How to fix
Upgrade to a fixed version: Mozilla Firefox 120.0; Mozilla Firefox ESR 115.5.0; Mozilla Thunderbird 115.5. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1861344
- https://lists.debian.org/debian-lts-announce/2023/11/msg00017.html
- https://lists.debian.org/debian-lts-announce/2023/11/msg00030.html
- https://www.debian.org/security/2023/dsa-5561
- https://www.mozilla.org/security/advisories/mfsa2023-49/
- https://www.mozilla.org/security/advisories/mfsa2023-50/
- https://www.mozilla.org/security/advisories/mfsa2023-52/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1861344
- https://lists.debian.org/debian-lts-announce/2023/11/msg00017.html
- https://lists.debian.org/debian-lts-announce/2023/11/msg00030.html
- https://www.debian.org/security/2023/dsa-5561
- https://www.mozilla.org/security/advisories/mfsa2023-49/
Get alerted when CVE-2023-6207 or the next vulnerability affects your stack