What’s Vulnerable › Vulnerabilities
CVE-2023-6242: EventON - WordPress Virtual Event Calendar Plugin Pro <= 4.5.4 & Free <= 2.2.7 - Cross-Site Request Forgery via evo_eventpost_update_meta
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-11 · updated 2026-06-17
- Weakness: CWE-352
Description
The EventON - WordPress Virtual Event Calendar Plugin plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.5.4 (for Pro) & 2.2.7 (for Free). This is due to missing or incorrect nonce validation on the evo_eventpost_update_meta function. This makes it possible for unauthenticated attackers to update arbitrary post metadata via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- EventON: before 4.5.5 — fixed in 4.5.5
- ashanjay EventON – Events Calendar: before 2.2.8 — fixed in 2.2.8
How to fix
Upgrade to a fixed version: EventON 4.5.5; ashanjay EventON – Events Calendar 2.2.8. Check the vendor advisory for mitigations.
References
- https://docs.myeventon.com/documentations/eventon-changelog/
- https://plugins.trac.wordpress.org/changeset/3017578/eventon-lite/trunk/includes/admin/class-admin-ajax.php
- https://plugins.trac.wordpress.org/changeset/3017939
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c8e9a333-a6b7-4b5e-93c1-b95566e5d6fb?source=cve
- https://docs.myeventon.com/documentations/eventon-changelog/
- https://plugins.trac.wordpress.org/changeset/3017578/eventon-lite/trunk/includes/admin/class-admin-ajax.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c8e9a333-a6b7-4b5e-93c1-b95566e5d6fb?source=cve
Get alerted when CVE-2023-6242 or the next vulnerability affects your stack