What’s Vulnerable › Vulnerabilities

CVE-2023-6244: EventON - WordPress Virtual Event Calendar Plugin <= 4.5.4 (Pro) & <= 2.2.8 (Free) - Cross-Site Request Forgery via save_virtual_event_settings

Description

The EventON - WordPress Virtual Event Calendar Plugin plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.5.4 (Pro) & 2.2.8 (Free). This is due to missing or incorrect nonce validation on the save_virtual_event_settings function. This makes it possible for unauthenticated attackers to modify virtual event settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

Affected products

How to fix

Upgrade to a fixed version: EventON 4.5.5; ashanjay EventON – Events Calendar 2.2.9. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-6244 or the next vulnerability affects your stack