What’s Vulnerable › Vulnerabilities
CVE-2023-6247
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-29 · updated 2026-06-17
- Weakness: CWE-476
Description
The PKCS#7 parser in OpenVPN 3 Core Library versions through 3.8.3 did not properly validate the parsed data, which would result in the application crashing.
Affected products
- OpenVPN 3 Core Library: before 3.8.4 — fixed in 3.8.4
How to fix
Upgrade to a fixed version: OpenVPN 3 Core Library 3.8.4. Check the vendor advisory for mitigations.
References
- https://community.openvpn.net/openvpn/wiki/CVE-2023-6247
- https://community.openvpn.net/openvpn/wiki/CVE-2023-6247
Get alerted when CVE-2023-6247 or the next vulnerability affects your stack