What’s Vulnerable › Vulnerabilities
CVE-2023-6257: Inline Related Posts < 3.6.0 - Subscriber+ Password Protected Post Read
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-11 · updated 2026-06-17
Description
The Inline Related Posts WordPress plugin before 3.6.0 is missing authorization in an AJAX action to ensure that users are allowed to see the content of the posts displayed, allowing any authenticated user, such as subscriber to retrieve the content of password protected posts
Affected products
- Inline Related Posts: before 3.6.0 — fixed in 3.6.0
How to fix
Upgrade to a fixed version: Inline Related Posts 3.6.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/19a86448-8d7c-4f02-9290-d9f93810e6e1/
- https://wpscan.com/vulnerability/19a86448-8d7c-4f02-9290-d9f93810e6e1/
Get alerted when CVE-2023-6257 or the next vulnerability affects your stack