What’s Vulnerable › Vulnerabilities
CVE-2023-6272: Theme My Login 2FA < 1.2 - Lack of Rate Limiting
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-12-18 · updated 2026-06-17
- Weakness: CWE-307
Description
The Theme My Login 2FA WordPress plugin before 1.2 does not rate limit 2FA validation attempts, which may allow an attacker to brute-force all possibilities, which shouldn't be too long, as the 2FA codes are 6 digits.
Affected products
- tml-2fa: before 1.2 — fixed in 1.2
How to fix
Upgrade to a fixed version: tml-2fa 1.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a03243ea-fee7-46e4-8037-a228afc5297a
- https://wpscan.com/vulnerability/a03243ea-fee7-46e4-8037-a228afc5297a
Get alerted when CVE-2023-6272 or the next vulnerability affects your stack