What’s Vulnerable › Vulnerabilities
CVE-2023-6357: OS Command Injection in multiple CODESYS products
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-05 · updated 2026-06-17
- Weakness: CWE-78
Description
A low-privileged remote attacker could exploit the vulnerability and inject additional system commands via file system libraries which could give the attacker full control of the device.
Affected products
- CODESYS Control for BeagleBone SL: before 4.11.0.0 — fixed in 4.11.0.0
- CODESYS Control For Empc-A/Imx6: before 4.11.0.0 — fixed in 4.11.0.0
- CODESYS Control for IOT2000 SL: before 4.11.0.0 — fixed in 4.11.0.0
- CODESYS Control for Linux ARM SL: before 4.11.0.0 — fixed in 4.11.0.0
- CODESYS Control for Linux SL: before 4.11.0.0 — fixed in 4.11.0.0
- CODESYS Control for PFC100 SL: before 4.11.0.0 — fixed in 4.11.0.0
- CODESYS Control for PFC200 SL: before 4.11.0.0 — fixed in 4.11.0.0
- CODESYS Control for PLCnext SL: before 4.11.0.0 — fixed in 4.11.0.0
- CODESYS Control for Raspberry Pi SL: before 4.11.0.0 — fixed in 4.11.0.0
- CODESYS Control for WAGO Touch Panels 600 SL: before 4.11.0.0 — fixed in 4.11.0.0
- CODESYS Runtime Toolkit: before 3.5.19.50 — fixed in 3.5.19.50
How to fix
Upgrade to a fixed version: CODESYS Control for BeagleBone SL 4.11.0.0; CODESYS Control For Empc-A/Imx6 4.11.0.0; CODESYS Control for IOT2000 SL 4.11.0.0; CODESYS Control for Linux ARM SL 4.11.0.0; CODESYS Control for Linux SL 4.11.0.0; CODESYS Control for PFC100 SL 4.11.0.0; CODESYS Control for PFC200 SL 4.11.0.0; CODESYS Control for PLCnext SL 4.11.0.0; CODESYS Control for Raspberry Pi SL 4.11.0.0; CODESYS Control for WAGO Touch Panels 600 SL 4.11.0.0; CODESYS Runtime Toolkit 3.5.19.50. Check the vendor advisory for mitigations.
References
- https://https://cert.vde.com/en/advisories/VDE-2023-066
- https://cert.vde.com/en/advisories/VDE-2023-066
- https://https://cert.vde.com/en/advisories/VDE-2023-066
Get alerted when CVE-2023-6357 or the next vulnerability affects your stack