What’s Vulnerable › Vulnerabilities
CVE-2023-6371: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-28 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue has been discovered in GitLab CE/EE affecting all versions before 16.8.5, all versions starting from 16.9 before 16.9.3, all versions starting from 16.10 before 16.10.1. A wiki page with a crafted payload may lead to a Stored XSS, allowing attackers to perform arbitrary actions on behalf of victims.
Affected products
- GitLab: before 16.8.5; from 16.9.0 before 16.9.3; 16.10.0 — fixed in 16.8.5, 16.9.3
How to fix
Upgrade to a fixed version: GitLab 16.8.5, 16.9.3. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/433021
- https://hackerone.com/reports/2257080
- https://gitlab.com/gitlab-org/gitlab/-/issues/433021
- https://hackerone.com/reports/2257080
Get alerted when CVE-2023-6371 or the next vulnerability affects your stack